! Enable IPv6
ipv6 cef
ipv6 unicast-routing

! Enable IPv6 and Prefix Delegation on the WAN interface
interface Dialer0
 ipv6 address autoconfig default
 ipv6 enable
 ipv6 dhcp client pd NODE-PD rapid-commit
ipv6 route ::/0 Dialer0

! Enable IPv6 and Prefix Delegation on the LAN interface
interface Vlan1
 ipv6 address NODE-PD ::1/64
 ipv6 enable
  
! IOS fails to refresh DHCPv6 PD after reconnecting. Workaround:
event manager applet MONITOR-IPV6-DHCP-APP 
 event syslog pattern "DIALER-6-BIND"
 action 1.0 cli command "enable"
 action 1.1 cli command "clear ipv6 dhcp client Dialer0"
 action 2.0 syslog priority debugging msg "Refreshed IPv6 DHCP PD lease (Dialer rebind)






ipv6 inspect name STD6 udp
ipv6 inspect name STD6 ftp
ipv6 inspect name STD6 icmp

ipv6 access-list INTERNET-IN-ACL6
 permit icmp any any
 permit tcp any any established
 permit udp any any eq 546
 deny ipv6 any any

ipv6 access-list DENY-ACL6
 permit icmp any any
 permit tcp any any established
 deny ipv6 any any

interface Dialer0
 ipv6 verify unicast reverse-path
 ipv6 inspect STD6 out
 ipv6 traffic-filter INTERNET-IN-ACL6 in

interface Vlan1
 ipv6 verify unicast reverse-path
 ipv6 inspect STD6 out
 ipv6 traffic-filter DENY-ACL6 out